The sunn Forum

Sunn Musical Equipment => Q & A => Topic started by: joshjames86 on October 06, 2017, 04:45:05 am

Title: 1968 Sunn Sceptre reverb troubleshoot
Post by: joshjames86 on October 06, 2017, 04:45:05 am
Hello all. Long time viewer, first time posting.

I recently picked up a 1968 Sunn Sceptre for a good price being it has two issues. One the treble control acts in reverse. When treble is turned all the way down the amp plays and sounds great; when turned up the amp loses volume. For this I'm going to check the pots and wiring and go from there, unless someone has a different theory?

But more importantly; the reverb. I didn't get a chance to pull the tank out yet to inspect but how difficult are the two diagnose or replace (probably hard to find)? Reverb doesn't seem to work at all and if you turn the reverb knob up then amp starts to sound trebly. I'm going to look at it, check the wiring and test connections then go from there. But i'm curious if this is a common/well known issue and something treatable.

Otherwise the amp sounds good but I'd like to get it right all around before dropping money at an amp tech. Any help or feedback is appreciated. Thank you!
Title: Re: 1968 Sunn Sceptre reverb troubleshoot
Post by: GrannyGremlin on November 04, 2017, 10:43:31 am
Both of my vintage Sunns came to me with the reverb not working (1200s and a Solarus 6550 version).  In both cases the fix was to clean the reverb jacks and plugs at both ends; probably never been cleaned and they're old and grimey.  Surprised me that it was something so simple, but like I said, same fix on both amps.